android failed installing /data/local/tmp/app.apk

You must Login before you can answer or comment on any questions.

I'm getting a problem compiling for Android,

I'm using SDK: APIs 2.2 (Have tried 2.2 and 1.6) and the error its throwing is:

[TRACE] D/AndroidRuntime( 316): Shutting down VM
[TRACE] D/jdwp ( 316): adbd disconnected
[TRACE] I/AndroidRuntime( 316): NOTE: attach of thread 'Binder Thread #3' failed
[ERROR] Failed installing com.myname.myproject: pkg: /data/local/tmp/app.apk
[TRACE] Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY]
[TRACE]
Whats strange is its a sporadic issue, it didnt work for a good couple of hours, than ran fine for the next 6 hours or so, then its started erroring again. Kitchen sink also fails to start in Android now where it worked fine before.

Any ideas appreciated

6 Answers

Seem to have solved it, went into the Android SJK and AVD manager, clicked on the Virtual Device I wanted, clicked Start, Selected 'Wipe user data' and then launched it.

Back in appcelerator my project started up as usual.

A bit concerned about whats causing it though...

— answered 4 years ago by Leigh Kayley
answer permalink
1 Comment
  • I also had to delete the other Titanium AVD from the manager.

    Then I got a Runtime error (TypeError: cannot call method ...) when loading on the emulator (and device) that was solved by changing the Titanium SDK from 1.4.0 to 1.3.0.

    — commented 4 years ago by Paul Beusterien

In addition to the API 2.2 from Google, I used the method by Leigh (search for his solution in this thread). Then I quit the 3 things: AVD manager, the emulator and Titanium. Ran Titanium again, went to test, clicked on "Launch", and voila!

I know this post is pretty old but I was getting the same error for a completely different reason. This page is indexed by google for the bug above, and I wanted to share. First off, make sure you have your titanium debug level set to Trace. You can do that by changing the Filter: option next to the launch button.

My client was using an old version of the android sdk. They wanted it to work for API 1.6. I had to go in and make a custom AndroidManifest.xml file. You can do this by copying the original file and calling it AndroidManifest.custom.xml. Once you have your custom file change

<uses-sdk android:minSdkVersion="7" />

to

<uses-sdk android:minSdkVersion="4" />

Then launch your app. You can find more information on minSdkVersion at http://developer.android.com/guide/topics/manifest/uses-sdk-element.html#min

1- you have to install android sdk tool 2- go to Android sdk tool-->sdk manager(android sdk avd manager) 3- you must check some packages which were installed before http://developer.appcelerator.com/question/35751/error-failed-installing--pkg-datalocaltmpappapk 4- In the virtual device part there is AVD which is default name "titanium_1_HVGA" edit it. 5-Change target google API level 8 my problem was solved like this method.

This issue is normally caused when trying to install an application on a non "Google API" emulator or device. If the project uses maps, it must use an emulator that starts with "Api" (e.g. "Api 1.6").

Your Answer

Think you can help? Login to answer this question!