Error : Prefix.pch' has been modified since the precompiled header was buil, why ?

You must Login before you can answer or comment on any questions.

Titanium 2.3

IOS : 6.0

problem: when i try to run the mobile application from ios simulator sometimes i get the following error: appname_Prefix.pch' has been modified since the precompiled header was built.

what is the cause of this error and what may be the possible solution

2 Answers

Hi Naveen, are you trying to build from Xcode after initial build from Titanium. if that is so then clean your titanium build and do that again.

else you post some log message here to help you better.

— answered 1 year ago by Ashish Nigam
answer permalink
5 Comments
  • not building from Xcode. Building from Titanium studio itself. There is noting in log file Although on console it displays message like this:

    ERROR] Error: Traceback (most recent call last):

    File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/builder.py", line 1325, in main execute_xcode("iphonesimulator%s" % link_version,["GCC_PREPROCESSOR_DEFINITIONS=LOG__ID=%s DEPLOYTYPE=development TI_DEVELOPMENT=1 DEBUG=1 TI_VERSION=%s %s %s" % (log_id,sdk_version,debugstr,kroll_coverage)],False) File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/builder.py", line 1231, in execute_xcode output = run.run(args,False,False,o) File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/run.py", line 41, in run sys.exit(rc) SystemExit: 65

    — commented 1 year ago by naveen yadav

  • ok, so can you do one thing, after this build open the build project in Xcode and run from there. What ever error message it give put in here.

    — commented 1 year ago by Ashish Nigam

  • ok but thing is SOMETIMES i get this error , when i re-build after deleting the bulid folder it ran fine. In case i get the error again i'll ran it from Xcode and will post the error.

    appreciate your help

    — commented 1 year ago by naveen yadav

  • Show 2 more comments

not building from Xcode. Building from Titanium studio itself. There is noting in log file Although on console it displays message like this:

ERROR] Error: Traceback (most recent call last):

File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/builder.py", line 1325, in main execute_xcode("iphonesimulator%s" % link_version,["GCC_PREPROCESSOR_DEFINITIONS=LOG__ID=%s DEPLOYTYPE=development TI_DEVELOPMENT=1 DEBUG=1 TI_VERSION=%s %s %s" % (log_id,sdk_version,debugstr,kroll_coverage)],False) File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/builder.py", line 1231, in execute_xcode output = run.run(args,False,False,o) File "/Users/User/Library/Application Support/Titanium/mobilesdk/osx/2.1.4.GA/iphone/run.py", line 41, in run sys.exit(rc) SystemExit: 65

Your Answer

Think you can help? Login to answer this question!