Can't get an app working on Android Emulator. Would appreciate any help getting it running.

You must Login before you can answer or comment on any questions.

I am a complete Titanium noob, and new to to the Android SDK as well. I installed Titanium Studio on two machines, a Win7 Ult. 64bit machine, and a MacBook Pro (Lion OSX). On the MacBook, I can build and run an app in iOS just fine. Trying to run in Android on either machine fails. Just to be clear, the Android emulator launches just fine, but the app doesn't get installed and run on the emulator.

I've installed API 7 and 8, as well as the Google API's for those (and many others). Java is installed, and I've tried to make sure the PATH settings are correct (in Windows anyway). If I open a terminal and type in JAVAC I get back all the help options as expected.

I was getting one error - on the Windows machine at least (not sure on the MacBook) it was complaining that it expected v1.6.x of Java and I have the latest 1.7.x. I fixed this by editing the prereq.py file(s) and changing the 1.6 to 1.7 so that it would build.

I am not seeing any other errors that appear relevant (nothing in red at least). The log file is here: http://www.seaburydesign.com/log.txt

If anyone has any suggestions, I would GREATLY appreciate it. Thanks.

— asked 2 years ago by Todd Davis
3 Comments
  • Do you get any other error ? Can post the INFO part getting printed in Titanium studio's console ?

    — commented 2 years ago by Yogin Bhungalia

  • Everything from the console is in this text file:

    http://www.seaburydesign.com/log.txt

    I see some warnings, but I don't see any errors. (Nothing is in red).

    — commented 2 years ago by Todd Davis

  • It is a very long log file which is why I linked to it as opposed to posting it here.

    — commented 2 years ago by Todd Davis

1 Answer

I know this will sound silly, but have you left the emulator running for another minute or so after it gets to where your .txt file shows it stopping?

I've been duped before...in to thinking the emulator has stalled or quit working only to find out that it just wasn't finished yet. The first build is torture.

Your Answer

Think you can help? Login to answer this question!