iPhone App on iPad

You must Login before you can answer or comment on any questions.

Hello, I'm currently working on a large iPhone app that was created using Titanium 1.7.2. When testing this app on and iPad, it opens as a full iPad app and not as a simulated iPhone app on the iPad. Is there anyway to fix this (turn off universal builds).

3 Answers

Accepted Answer

Looks like the first setting of universal app sticks even though you uncheck iPad later. Try creating a new project for iPhone only, copy your Resources folder and build.

— answered 3 years ago by Chris Magnussen
answer permalink
1 Comment
  • That actually didn't work for me when I first tried it. But I tried it again and it seems to work if I do a shallow copy of the Resources. Thanks.

    — commented 3 years ago by Byron Carasco

You should be able to uncheck iPad in the tiapp.xml.

— answered 3 years ago by Chris Magnussen
answer permalink
1 Comment
  • I try that, and clean the build, and build it again, then open the project in Xcode and it still runs as a full iPad app.

    — commented 3 years ago by Byron Carasco

In Titanium there is a button above the project files box in which you can choose the simulator. When you created the project did you choose Iphone and Ipad project?, and if you didnt as Chris mentioned modifiying tiapp.xml is the solution, after that close and re'open the project.

— answered 3 years ago by Mario Navarro Palos
answer permalink
1 Comment
  • It still seems to think it's a full iPad app when I test it on the iPad simulator. It works fine (and always has) when I test it on the iPhone simulator. True, when I disable iPhone in tiapp.xml, the option to Run on iPad disappears from Studio, it still doesn't behave correctly when I try to run it on the iPad simulator from the xcode proj in the build folder.

    — commented 3 years ago by Byron Carasco

Your Answer

This question has been locked and cannot accept new answers.