Problem with the Android SDK installation in Titanium

You must Login before you can answer or comment on any questions.

This been posted a few times but none of the replies have solved it for me. Maybe I'm being really thick here, but could someone please explain this and please type slowly... ;)

I followed the instructions from here: http://developer.android.com/sdk/index.html

Really doesn't say much, but here's what I did:

  1. Downloaded the SDK (OS X)

  2. Expanded it in the same catalog: /Users/Jocke/Downloads/android-sdk-mac_86

  3. Run Android from /Users/Jocke/Downloads/android-sdk-mac_86/tools/android

  4. Download all packages in the Android SDK and AVD Manager.

  5. Set the Android SDK in my profile in Titanium to: /Users/Jocke/Downloads/android-sdk-mac_86

  6. Restart Titanium

Trying to create a 1.3 project gets me: 1. Green checkmark next to the Android SDK. 2. Project Creation error: Error creating project when saving.

From what I've read this is due to an incorrect installation of the Android SDK. But I can't understand what I've done wrong?

(I can get around this by saving the project as 1.2, but that's not a solution as the Android tab then don't show up under "Run Emulator" in Titanium.)

Do I need to add the path to the Android SDK in OS X? How do I do that in such case?

Any help highly appreciated!

/J

3 Answers

It might be permissions related since you left it in your Downloads folder, but that's just a guess. Look through our guide and see if that helps.

The other question I should as is where are you trying to create your Titanium project?

Also try importing Kitchen Sink to see if you're able to launch it.That will help isolate the problem as well.

We have a winner! =)

After some serious confusion I finally ironed everything out - THANKS!

Since I'm fairly new to Macs (took the plunge and ditched Windows about a year ago) I found some of these instructions less then exhaustive.

I'm jotting down a few notes for future reference by other confused souls:

I could guess what a symlink is but here's a brief tutorial for reference: http://www.macosxhints.com/article.php?story=2001110610290643

I run my normal account as a Non Admin and could'nt remember (or if I haven't enabled the root account). Solved it by logging in as admin and followed the instructions here to reset/enable root: http://www.macosxhints.com/article.php?story=20010324095804436

While logged in with admin I created the symlink. I choose to put the android catalog to the general Applications folder: /Applications, so I can reach it from multiple accounts, like so: sudo ln -s /Applications/android-sdk-mac_86/ android-sdk

NOTICE! The instructions says. "/Applications/android-sdk-mac/" but if you just except the default when you extract it will be "/Applications/android-sdk-mac_86/".

OS X don't have an "/opt"-catalog per default, you need to create it. Note that you need to be logged in with the account that you're going to use (each account gets it's own "/opt"-catalog.

Setting the path caused me some concern since everything that starts with a dot(.) in OS X is hidden from Finder. The simplest(?) way was to write this in terminal while standing in your home catalog:

cd ~ (makes sure you're in your home catalog)

open -a textedit .profile (Forces the file to open in the TextEdit.app)

With the file open simply append the Path to the bottom like this:

PATH=/opt/android-sdk/tools:$PATH export PATH

There's an ERROR in the instructions that says you should include: "PATH=/opt/android-sdk/platforms/android-1.5/tools:$PATH" as well. But this path doesn't exist with the current version of the Android SDK.

This causes one more error in the docs for: "Verify the ADK Install From a new command window run the following two commands aapt v"

This will never work as aapt is'nt to be found in the path. The file is located in /Application/android-sdk-mac_86/platforms/android-3/tools/. Couldn't hurt to include this instead, but my Android Simulator works fine without it (so far).

To check on your path you can type "export" in Terminal. (Make sure you open a new terminal window after editing the .profile-file, or else the Path doesn't seem to be updated).

There's a broken image in the documentation:

Installing the iPhone SDK Verify the Install TBD You should see something similar to the image below.

[broken image]

There's a broken link in the documentation:

Installing the Android Development Kit (ADK) Download the ADK from the Google Android Developer site.

Hope that helps someone!

/J

— answered 5 years ago by Joacim Boive
answer permalink
1 Comment
  • I edited your post to add formatting. Couple of things to add. You want android-4 not android-3 we no longer support Android 1.5 which is API Level 3.

    We will be updating the doc and pictures soon. Google keeps changing the names of things which makes it difficult to keep the documentation timely.

    You should be able to create /opt using sudo

    sudo mkdir /opt

    — commented 5 years ago by Don Thorp

I have tried to work through the guide supplemented with this thread and some minor differences (Google API is under third party plugins now) but have had no luck so far. Verifying the install with aapt v and android list is working but Titanium is still throwing all kinds of errors and refusing to load an Emulator. I see your post mentions the guide will be updated soon as of 11 months ago, I would love to see some attention given to improving the guide.

Your Answer

Think you can help? Login to answer this question!