Error installing CLI

You must Login before you can answer or comment on any questions.

I've just updated Titanium to 3.0 and I'm trying to install CLI but I get this error

ERR! Error: No compatible version found: read@'>=1.0.0- <1.1.0-'
ERR! Valid install targets:
ERR! ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
ERR!     at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:486:10)
ERR!     at next_ (/usr/local/lib/node_modules/npm/lib/cache.js:436:17)
ERR!     at next (/usr/local/lib/node_modules/npm/lib/cache.js:413:44)
ERR!     at /usr/local/lib/node_modules/npm/lib/cache.js:406:5
ERR!     at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:151:7)
ERR!     at Object.oncomplete (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:230:7)
ERR! You may report this log at:
ERR!     <>
ERR! or email it to:
ERR!     <>
ERR! System Darwin 12.2.0
ERR! command "node" "/usr/local/bin/npm" "-g" "install" "titanium"
ERR! cwd /Applications/Titanium Studio/
ERR! node -v v0.6.17
ERR! npm -v 1.1.21
ERR! message No compatible version found: read@'>=1.0.0- <1.1.0-'
ERR! message Valid install targets:
ERR! message ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
verbose exit [ 1, true ]
log file /Applications/Titanium Studio/

Any help?

Thank you, Stefano.

1 Answer

Your Answer

Think you can help? Login to answer this question!