Can't update Studio

You must Login before you can answer or comment on any questions.

Am I the only one who always gets a similar message when prompted that there are updates available (for Studio, NOT SDK updates)?

An error occurred while collecting items to be installed
session context was:(profile=AppceleratorProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.appcelerator.titanium.branding,1.0.9.1327100657
No repository found containing: osgi.bundle,com.appcelerator.titanium.core,1.0.7.1328807407
No repository found containing: osgi.bundle,com.appcelerator.titanium.mobile,1.0.0.1328807407
No repository found containing: osgi.bundle,com.appcelerator.titanium.rcp,1.0.9.201202141208
No repository found containing: osgi.bundle,com.appcelerator.titanium.rcp.studio,1.0.0.201202141208
No repository found containing: osgi.bundle,com.appcelerator.titanium.ui.ide,1.0.6.1328742482
No repository found containing: osgi.bundle,com.aptana.branding,3.0.9.1327100469
No repository found containing: osgi.bundle,com.aptana.editor.common,3.0.3.1328568823
No repository found containing: osgi.bundle,com.aptana.editor.css.formatter,3.0.0.1327409849
No repository found containing: osgi.bundle,com.aptana.editor.php,3.0.3.1327100530
No repository found containing: osgi.bundle,com.aptana.editor.php.epl,3.0.0.1327100530
No repository found containing: osgi.bundle,com.aptana.editor.php.formatter,3.0.0.1327100530
No repository found containing: osgi.bundle,com.aptana.git.ui,3.0.3.1328222732
No repository found containing: osgi.bundle,com.aptana.portal.ui.eclipse35,3.0.0.1329151902
No repository found containing: osgi.bundle,com.aptana.ruby.debug.core,3.0.2.1327600259
No repository found containing: osgi.bundle,com.aptana.ruby.launching,3.0.2.1327600259
No repository found containing: osgi.bundle,com.aptana.ruby.rake,3.0.0.1327600259
No repository found containing: osgi.bundle,com.aptana.samples.ui,3.0.0.1327541770
No repository found containing: osgi.bundle,com.aptana.usage,3.0.0.1329151902
No repository found containing: osgi.bundle,com.python.pydev,2.4.0.2012020116
No repository found containing: osgi.bundle,com.python.pydev.analysis,2.4.0.2012020116
No repository found containing: osgi.bundle,com.python.pydev.codecompletion,2.4.0.2012020116
No repository found containing: osgi.bundle,com.python.pydev.debug,2.4.0.2012020116
No repository found containing: osgi.bundle,com.python.pydev.fastparser,2.4.0.2012020116
No repository found containing: osgi.bundle,com.python.pydev.refactoring,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.ast,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.core,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.customizations,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.debug,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.django,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.django_templates,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.help,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.jython,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.parser,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.red_core,2.4.0.2012020116
No repository found containing: osgi.bundle,org.python.pydev.refactoring,2.4.0.2012020116
No repository found containing: org.eclipse.update.feature,com.appcelerator.titanium.feature,1.0.9.1329151903-6-7N79BAODG9MDJ7DG9OgHmSsdc3
No repository found containing: org.eclipse.update.feature,com.appcelerator.titanium.feature.rcp,1.0.9.201202141208-7e7aDfFFsJ-BOVP-2Ztf0FRchlN4
No repository found containing: binary,com.appcelerator.titanium.rcp.product.rootfiles.cocoa.macosx.x86,1.0.9.201202141208-14022012121043
No repository found containing: org.eclipse.update.feature,com.appcelerator.titanium.studio,1.0.9.1329151903-7E-7X7c-iKKmOEPO
No repository found containing: org.eclipse.update.feature,com.aptana.feature,3.0.9.1329151902-BJ7F8NBTEBQakdyRh1DC34EVnIM5
No repository found containing: org.eclipse.update.feature,com.aptana.feature.studio,3.0.9.201202140953-7E777Q7HFGVBKBSEW7S_Iz0JktqM
No repository found containing: org.eclipse.update.feature,com.aptana.php.feature,3.0.9.1327100530-7D-27CEBQ855KE5
No repository found containing: org.eclipse.update.feature,org.python.pydev.django_templates.feature,2.4.0.2012020116
No repository found containing: org.eclipse.update.feature,org.python.pydev.feature,2.4.0.2012020116
No repository found containing: org.eclipse.update.feature,org.radrails.rails,3.0.9.201202130945-7e-7Q7f4oUM8Bz0He

— asked 3 years ago by Josh Lewis
2 Comments
  • In the Titanium Studio, click Help then click Check for Updates.

    — commented 3 years ago by Nikhil Sharma

  • Hello,

    please get the logs from the help->titanium studio logs and share it with me at mpmiranda@appcelerator.com

    — commented 3 years ago by Mauro Parra

1 Answer

Accepted Answer

I experienced the exactly the same issue. My issue was solved by this

Specifically this solved my issue:

> Studio has incorrectly cached some metadata from the update site. Follow the instructions above for No updates were found.

— answered 3 years ago by Minh Nguyen
answer permalink
1 Comment
  • That seemed to fix it, I had to temporarily un-check all of the entries EXCEPT the Titanium Studio site, even though they were all connecting fine. Weird. THanks

    — commented 3 years ago by Josh Lewis

Your Answer

Think you can help? Login to answer this question!